Skip to content

Division Points

Class full path: NemAll_Python_Geometry.DivisionPoints

Class for DivisionPoints

Functions

Count()

Get number of division points

Returns:

Type Description
int

number of division points

GetEndPoint()

Get the end point

Returns:

Type Description
Point3D

End Point

GetEndPointAngle()

Get the angle at the end point

Returns:

Type Description
Angle

Angle at the end point

GetPoint(index)

Get division point

Parameters:

Name Type Description Default
index int

index of the division point

required

Returns:

Type Description
Point3D

division point as Point3D

GetPointAngle(index)

Get the angle of a division point

Parameters:

Name Type Description Default
index int

index of the division point

required

Returns:

Type Description
Angle

angle as Angle

GetPointAngles()

Get the angles of the division points

Returns:

Type Description
AngleList

copy of the angles of the division points as vector of Angle

GetPoints()

Get the calculated division points

Returns:

Type Description
Point3DList

copy of the division points as vector of Point3D

GetStartPoint()

Get the start point

Returns:

Type Description
Point3D

Start Point

GetStartPointAngle()

Get the angle at the start point

Returns:

Type Description
Angle

Angle at the start point

IsSuccessful()

Get the result of the computation

Returns:

Type Description
bool

Computation successful: true / false

__init__ overload

__init__(path, sectionLength, eps)

Constructor

Parameters:

Name Type Description Default
path Path2D

Path to divide

required
sectionLength float

length of one division section

required
eps float

tolerance

required
__init__(geoObject, number, eps)

Constructor

Parameters:

Name Type Description Default
geoObject object

object to divide

required
number int

number of division points

required
eps float

tolerance

required
__init__(path, number, eps)

Constructor

Parameters:

Name Type Description Default
path Path2D

Path to divide

required
number int

number of division points

required
eps float

tolerance

required
__init__(geoObject, sectionLength, eps)

Constructor

Parameters:

Name Type Description Default
geoObject object

object to divide

required
sectionLength float

length of one division section

required
eps float

tolerance

required