Skip to content

Tangent Calculus

Class full path: NemAll_Python_Geometry.TangentCalculus

Tangent calculation at an element point

Functions

Calculate overload

Calculate(line) staticmethod

Calculates tangent vector of Line2D

Parameters:

Name Type Description Default
line Line2D

Line2D on which to calculate tangent vector

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(line) staticmethod

Calculates tangent vector of Line3D

Parameters:

Name Type Description Default
line Line3D

line on which to calculate tangent vector

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(polyline, inputPnt) staticmethod

Calculates tangent vector of Polyline2D at given point

Parameters:

Name Type Description Default
polyline Polyline2D

Polyline on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(polyline, inputPnt) staticmethod

Calculates tangent vector of Polyline2D at given point

Parameters:

Name Type Description Default
polyline Polyline3D

Polyline on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(polygon, inputPnt) staticmethod

Calculates tangent vector of Polygon2D at given point

Parameters:

Name Type Description Default
polygon Polygon2D

Polygon on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(arc, inputPnt) staticmethod

Calculates tangent vector of Arc2D at given point

Parameters:

Name Type Description Default
arc Arc2D

Arc2D on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(arc, inputPnt) staticmethod

Calculates tangent vector of Arc3D at given point

Parameters:

Name Type Description Default
arc Arc3D

Arc3D on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(spline, inputPnt) staticmethod

Calculates tangent vector of Spline2D at given point

Parameters:

Name Type Description Default
spline Spline2D

Spline on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(spline, inputPnt) staticmethod

Calculates tangent vector of Spline2D at given point

Parameters:

Name Type Description Default
spline Spline3D

Spline on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(bspline, inputPnt) staticmethod

Calculates tangent vector of BSpline2D at given point

Parameters:

Name Type Description Default
bspline BSpline2D

BSpline on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(bspline, inputPnt) staticmethod

Calculates tangent vector of BSpline3D at given point

Parameters:

Name Type Description Default
bspline BSpline3D

BSpline on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(clothoid, inputPnt) staticmethod

Calculates tangent vector of Clothoid2D at given point

Parameters:

Name Type Description Default
clothoid Clothoid2D

Clothoid on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(path, inputPnt) staticmethod

Calculates tangent vector of Path2D at given point

Parameters:

Name Type Description Default
path Path2D

Path on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

Calculate(brep, inputPnt) staticmethod

Calculates tangent vector of BRep3D at given point

Parameters:

Name Type Description Default
brep BRep3D

Brep body

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3DList

tangent vectors

Calculate(geoObject, inputPnt) staticmethod

Calculates tangent vector from object at given point

Parameters:

Name Type Description Default
geoObject object

object on which to calculate tangent vector

required
inputPnt Point3D

point on object for tangent calculation

required

Returns:

Type Description
Vector3D

tangent vector

CalculateNormal(brep, inputPnt) staticmethod

Calculates normal vector of BRep3D at given point

Parameters:

Name Type Description Default
brep BRep3D

Brep body

required
inputPnt Point3D

point on object for normal calculation

required

Returns:

Type Description
Vector3D

normal vector