Skip to content

View

Class full path: PythonPart.View

Definition of a view class

Attributes

elements: List[Any] property

Get all elements

end_scale: float property

Get the reference end scale

start_scale: float property

Get the reference start scale

viewtype: AllplanBasisEle.MacroSlideType property

Get the type

visibility2d: bool property

Get the 2D visibility flag

visibility3d: bool property

Get the 3D visibility flag

visibility_layer_a: bool property writable

Get the Layer A visibility flag

visibility_layer_b: bool property writable

Get the Layer B visibility flag

visibility_layer_c: bool property writable

Get the Layer C visibility flag

Functions

__init__(viewtype=<span data-autorefs-optional-hover="NemAll_Python_BasisElements.MacroSlideType.eGeometry">eGeometry</span>, visibility2d=True, visibility3d=True, start_scale=0.0, end_scale=9999.0, elements=None)

initialization of view class

Parameters:

Name Type Description Default
viewtype

view type. Defaults to AllplanBasisElements.MacroSlideType.eGeometry.

eGeometry
visibility2d

visible in 2D. Defaults to True.

True
visibility3d

visible in 3D. Defaults to True.

True
start_scale

start scale. Defaults to 0.

0.0
end_scale

end scale. Defaults to 9999.

9999.0
elements

elements. Defaults to None.

None

__repr__()

create the element string

Returns:

Type Description
str

element string

add(element)

add one element

Parameters:

Name Type Description Default
element Any

element

required

create()

Create view

reset(elements)

Reset elements

Parameters:

Name Type Description Default
elements List[Any]

elements

required