Skip to content

Fixture Element

Class full path: NemAll_Python_Precast.FixtureElement

Bases: PrecastElement, AllplanElement

Representation of fixture

Functions

GetFixtureProperties()

Get the Fixture properties

Returns:

Type Description
FixtureProperties

Fixture properties

GetHash()

Get the hash value

Returns:

Type Description
str

Hash value

GetSlideList()

Get the slide object list

Returns:

Type Description
List[FixtureSlideElement]

Slide object list

SetFixtureProperties(fixProp)

Set the Fixture properties

Parameters:

Name Type Description Default
fixProp FixtureProperties

fixture properties

required

SetHash(hash)

Set the hash value

Parameters:

Name Type Description Default
hash str

Hash value

required

__init__ overload

__init__()

initialize

__init__(fixProp, slideList)

Constructor

Parameters:

Name Type Description Default
fixProp FixtureProperties

Fixture properties

required
slideList List[FixtureSlideElement]

Slide list of fixture definition

required

__repr__()

convert the list to a string