Skip to content

Structural Element Properties

Class full path: NemAll_Python_ArchElements.StructuralElementProperties

Bases: ArchBaseProperties

Implementation of Structural Framing Elements properties

Functions

AddHole(holeGeometry)

Adds a hole to the list of holes for the Structural Element

Parameters:

Name Type Description Default
holeGeometry BRep3D

3D BRep Geometry of the hole

required

Returns:

Type Description
int

Unique ID for the created hole

GetAnglesAtEnd()

Get angles between the cross-sectional area and the the plane perpendicular to the axis at the end of the structural framing element

Returns:

Type Description
Angle

angle in local X direction

Angle

angle in local Y direction

GetAnglesAtStart()

Get angles between the cross-sectional area and the the plane perpendicular to the axis at the start of the structural framing element

Returns:

Type Description
Angle

angle in local X direction

Angle

angle in local Y direction

GetBodyAxis()

Get Axis of Structural Element calculated in the cross section's center of gravity

Returns:

Type Description
Line3D

Axis

GetCenterAxis()

Get Axis of Structural Element canlculated in the center of the cross section outline

Returns:

Type Description
Line3D

Axis

GetEndPointAdditionalOffset()

Get the end point distance dx/dy

Returns:

Type Description
Vector3D

Vector3D with offsets in x and y like Vector3D(distance_dx, distance dy, 0)

GetEndPointZOffset()

Get the value of Z offset of the anchor point at end the point of Structural Framing Element

Returns:

Type Description
float

value of Z offset

GetEndReferencePointType()

Get type the reference point at end

Returns:

Type Description
CustomBoxPoint

CustomBoxPoint

GetHeightProperties()

Get Height Properties

Returns:

Type Description
PlaneReferences

Plane references

GetHoles()

Get holes in Structural Framing Element

Returns:

Type Description
dict

existing holes as python dictionary, where key is hole ID, value is its geometry

GetProfileAngle()

Get rotation angle of element profile around the element axis

Returns:

Type Description
Angle

Rotation angle

GetProfileShapeProperties()

Get cross-section shape properties

Returns:

Type Description
Union[RectangularShape, CircularShape, ProfileShape]

Cross-section properties

GetShapeTypeAtEnd()

Get truncation type at end point

Returns:

Type Description
SolidElementTruncationType

truncation type

GetShapeTypeAtStart()

Get truncation type at start point

Returns:

Type Description
SolidElementTruncationType

truncation type

GetSkeletonSolidElementProperties()

Get SkeletonSolidElementProperties

GetStartPointAdditionalOffset()

Get the start point distance dx/dy

Returns:

Type Description
Vector3D

Vector3D with offsets like Vector3D(distance_dx, distance dy, 0)

GetStartPointZOffset()

Get the value of Z offset of the anchor point at start the point of Structural Framing Element

Returns:

Type Description
float

value of Z offset

GetStartReferencePointType()

Get type of the reference point at start

Returns:

Type Description
CustomBoxPoint

CustomBoxPoint

GetZCoordsVisibility()

Get visibility of Z coordinates of insertion point

Returns:

Type Description
bool

True if Z coordinates visible, False otherwise

HasTwoAnchorPoints()

Get the value of the check box "Different anchor point at beginning and at end"

Returns:

Type Description
bool

True if the element has two different anchor points, False otherwise

RemoveHole(holeID)

Removes a hole to the list of holes for the Structural Element

Parameters:

Name Type Description Default
holeID int

ID of the hole to remove. This ID is obtained by AddHole operation

required

SetAnglesAtEnd(angleX, angleY)

Set angles between the cross-sectional area and the the plane perpendicular to the axis at the end of the structural framing element

Parameters:

Name Type Description Default
angleX Angle

angle in local X direction

required
angleY Angle

angle in local Y direction

required

SetAnglesAtStart(angleX, angleY)

Set angles between the cross-sectional area and the the plane perpendicular to the axis at the start of the structural framing element

Parameters:

Name Type Description Default
angleX Angle

angle in local X direction

required
angleY Angle

angle in local Y direction

required

SetAttribute(attrib)

Set the attribute

Parameters:

Name Type Description Default
attrib Union[AttributeInteger, AttributeDouble, AttributeString, AttributeEnum]

Attribute

required

SetCommonProperties(comProp)

Set the Common properties

Parameters:

Name Type Description Default
comProp CommonProperties

Common properties

required

SetEndPointZOffset(desiredOffset)

Set the value of Z offset of the anchor point at end the point of Structural Framing Element

Parameters:

Name Type Description Default
desiredOffset float

value of Z offset

required

SetProfileAngle(value)

Set rotation angle of element profile around the element axis

Parameters:

Name Type Description Default
value Angle

rotation angle

required

SetProfileShapeProperties(value)

Set cross-section shape properties

Parameters:

Name Type Description Default
value Union[RectangularShape, CircularShape, ProfileShape]

Profile Shape Properties

required

SetShapeTypeAtEnd(endTruncationType)

Set truncation type at end point

Parameters:

Name Type Description Default
endTruncationType SolidElementTruncationType

truncation type

required

SetShapeTypeAtStart(startTruncationType)

Set truncation type at start point

Parameters:

Name Type Description Default
startTruncationType SolidElementTruncationType

truncation type

required

SetStartPointZOffset(desiredOffset)

Set the value of Z offset of the anchor point at start the point of Structural Framing Element

Parameters:

Name Type Description Default
desiredOffset float

value of Z offset

required

SetTwoAnchorPoints(areTwoAnchorPoint)

Set the value of the check box "Different anchor point at beginning and at end"

Parameters:

Name Type Description Default
areTwoAnchorPoint bool

True if the element has two different anchor points, False otherwise

required

__init__ overload

__init__()

initialize

__init__(structuralElementProperties)

Copy constructor

Parameters:

Name Type Description Default
structuralElementProperties StructuralElementProperties

Structural Element properties

required