Skip to content

Associative View Properties

Class full path: NemAll_Python_BasisElements.AssociativeViewProperties

Attributes

AdjacentEdges: float property

Property for the angle in case RemoveAdjacentEdges is set to True

ColorHiddenEdge: int property

Property for hidden edges color ID

ColorVisibleEdge: int property

Property for visible edges color ID

ConvertTo2D: int property

Property for convert to 2D

ElementRepresentation: AssociativeViewElementRepresentation property

Set/get the element representation

Hidden: int property

Property for the calculation art: hidden or wire

LayerBoundaryLine: int property

Property for the boundary line layer

LayerFinishLine: int property

Property for the finish line layer

LayerHiddenEdge: int property

Property for the hidden edge layer

LayerHiddenSectionLine: int property

Property for the layer of the hidden section line

LayerSectionLine: int property

Property for the section line layer

LayerVisibleEdge: int property

Property for the visible edge layer

PenHiddenEdge: int property

Property for the hidden edge pen ID

PenVisibleEdge: int property

Property for the visible edge pen ID

RemoveAdjacentEdges: int property

Whether to remove adjacent edges

ShowHiddenEdges: int property

Whether to show hidden edges

ShowSectionBody: int property

Whether to show section body

ShowVisibleEdges: int property

Whether to show visibele edges

StrokeHiddenEdge: int property

Property for the hidden edge stroke ID

StrokeVisibleEdge: int property

Property for the visible edge stroke ID

Functions

__init__ overload

__init__()

initialize

__init__(doc)

Constructor

Parameters:

Name Type Description Default
doc DocumentAdapter

document adapter

required
__init__(arg)

Copy constructor

Parameters:

Name Type Description Default
arg AssociativeViewProperties

copy from

required