Rotation Util
Class full path: RotationUtil.RotationUtil
Implementation of the rotation utility
Attributes
angle_x: float
property
Get the x angle in degree
angle_y: float
property
Get the y angle in degree
angle_z: float
property
Get the y angle in degree
Functions
__init__(angle_x, angle_y, angle_z)
Set the model angles
angle_x Rotation (degree) around the local x axis to
get the global/local x/y/z coordinates of the shape
angle_y Rotation (degree) around the local y axis to
get the global/local x/y/z coordinates of the shape
angle_z Rotation (degree) around the local z axis to
get the global/local x/y/z coordinates of the shape
__repr__()
create a string from the object data
Returns:
Type | Description |
---|---|
string with the object data |
get_rotation_matrix(axis_point=Point3D())
get the rotation matrix
Parameters:
Name | Type | Description | Default |
---|---|---|---|
axis_point
|
Point3D
|
axis point. Defaults to AllplanGeo.Point3D(). |
Point3D()
|
Returns:
Type | Description |
---|---|
Matrix3D
|
rotation axis |