Skip to content

Mesh Area Placement Properties

Class full path: NemAll_Python_Reinforcement.MeshAreaPlacementProperties

Attributes

LapJointOffset: bool property

Get/set the lap joint offset state

MeshSizeRound: bool property

Get/set the mesh size round state

OverlapCross: float property

Get/set the cross overlap

OverlapLongitudinal: float property

Get/set the longitudinal overlap

PlacementDirection: MeshPlacementDirection property

Get/set the placement direction

PlacementEndJustified: bool property

Get/set the placement end justified state

PlacementStartChange: bool property

Get/set the placement start change state

StartLength: float property

Get/set the start length

StartWidth: float property

Get/set the start width

Classes

MeshPlacementDirection

Bases: IntEnum

Mesh placement direction

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key Union[str, int, float]

value key

required

Returns:

Type Description
MeshPlacementDirection

value for the key

Functions

__init__()

initialize

__repr__()

convert the list to a string