Skip to content

Fixture Properties

Class full path: NemAll_Python_Precast.FixtureProperties

Representation of properties od fixture definition

Attributes

CatalogName: str property

Property for catalog name

DomainType: int property

Property for domain type

InsertionPoint: Point3D property

Property for insertion point

IsScaleDependent: bool property

Property for scale dependent state

Name: str property

Property for name

PositionNr: int property

Property for position number

SubType: MacroSubType property

Property for sub type

Type: MacroType property

Property for type

UnitFactor: float property

Property for unit factor

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop FixtureProperties

Properties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

initialize

__repr__()

convert the list to a string