Skip to content

Divide Bars Parameters

Class full path: NemAll_Python_Reinforcement.DivideBarsParameters

Attributes

DivideMode: eDivideMode property

Get/set the divide mode

GapLength: float property

Get/set the gap Length

GapPosition: eLengthPosition property

Get/set the gap position

OverlapLength: float property

Get/set the overlap length

OverlapPosition: eLengthPosition property

Get/set the overlap position

Classes

eDivideMode

Bases: IntEnum

Divide mode

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key Union[str, int, float]

value key

required

Returns:

Type Description
eDivideMode

value for the key

eLengthPosition

Bases: IntEnum

Length position

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key Union[str, int, float]

value key

required

Returns:

Type Description
eLengthPosition

value for the key

Functions

Get()

Get method

Returns:

Type Description
DivideBarsParameters

Divide parameters

Set(parameters)

Set method

Parameters:

Name Type Description Default
parameters DivideBarsParameters

Divide parameters

required

__init__ overload

__init__()

initialize

__init__(maxLength, startLength, overlap, outputGeoAsInArray, evenMeshOffset)

Constructor

Parameters:

Name Type Description Default
maxLength eDivideMode

Limit length

required
startLength eLengthPosition

Length of start bar or mesh

required
overlap float

Overlapping length

required
outputGeoAsInArray eLengthPosition

Output geometry should to be as is stored in 'array' (shorter about half diameter on both ends of bar)

required
evenMeshOffset float

Move each even mesh

required
__init__(divideBarsParameters)

Copy constructor.

__repr__()

convert the list to a string