Skip to content

Visible Hidden Edges Properties

Class full path: NemAll_Python_BasisElements.VisibleHiddenEdgesProperties

Visible hidden edges properties

Attributes

HiddenEdgesColor: int property

Property for color ID for hidden edges

HiddenEdgesLayer: int property

Property for layer ID for hidden edges

HiddenEdgesLineType: int property

Property for stroke ID for hidden edges

HiddenEdgesPen: int property

Property for pen ID for hidden edges

IsHiddenEdgesColorFromLayer: bool property

Whether to get the color ID of the hidden edges from the layer definition

IsHiddenEdgesColorUsed: bool property

Whether to use the color specified in HiddenEdgesColor for drawing the hidden edges (true) or the color of the model elements (false)

IsHiddenEdgesLayerUsed: bool property

Whether to use the layer specified in HiddenEdgesLayer for drawing the hidden edges (true) or the layer of the model elements (false)

IsHiddenEdgesLineTypeFromLayer: bool property

Whether to get the stroke ID of the hidden edges from the layer definition

IsHiddenEdgesLineTypeUsed: bool property

Whether to use the stroke specified in HiddenEdgesLineType for drawing the hidden edges (true) or the stroke of the model elements (false)

IsHiddenEdgesOn: bool property

Whether to draw hidden edges

IsHiddenEdgesPenFromLayer: bool property

Whether to get the pen ID of the hidden edges from the layer definition

IsHiddenEdgesPenUsed: bool property

Whether to use the pen specified in HiddenEdgesPen for drawing the hidden edges (true) or the pen of the model elements (false)

IsVisibleEdgesColorFromLayer: bool property

Whether to get the color ID of the visible edges from the layer definition

IsVisibleEdgesColorUsed: bool property

Whether to use the color specified in VisibleEdgesColor for drawing the visible edges (true) or the color of the model elements (false)

IsVisibleEdgesLayerUsed: bool property

Whether to use the layer specified in VisibleEdgesLayer for drawing the visible edges (true) or the layer of the model elements (false)

IsVisibleEdgesLineTypeFromLayer: bool property

Whether to get the stroke ID of the visible edges from the layer definition

IsVisibleEdgesLineTypeUsed: bool property

Whether to use the stroke specified in VisibleEdgesLineType for drawing the visible edges (true) or the stroke of the model elements (false)

IsVisibleEdgesOn: bool property

Whether to draw visible edges

IsVisibleEdgesPenFromLayer: bool property

Whether to get the pen ID of the visible edges from the layer definition

IsVisibleEdgesPenUsed: bool property

Property for custom pen used for visible edges

VisibleEdgesColor: int property

Property for color ID for visible edges

VisibleEdgesLayer: int property

Property for layer ID for visible edges

VisibleEdgesLineType: int property

Property for stroke ID for visible edges

VisibleEdgesPen: int property

Property for pen ID for visible edges

Functions

__init__()

initialize