Skip to content

Allplan Version

Class full path: NemAll_Python_AllplanSettings.AllplanVersion

Class for extraction of Allplan version information

Functions

MainReleaseName() staticmethod

Get the Allplan main release name

Returns:

Type Description
str

Allplan main release name ('2016', '2017', ...)

Examples:

>>> AllplanVersion.MainReleaseName()
2023

SubReleaseName() staticmethod

Get the Allplan sub release name

Returns:

Type Description
str

Allplan sub release name ('2016.0', '2016.1', ...)

Examples:

>>> AllplanVersion.SubReleaseName()
2023.1

Version() staticmethod

Get the Allplan version as string Returns: Allplan version

Examples:

>>> AllplanVersion.Version()
2023.1

WindowsReleaseName() staticmethod

Get the Allplan window release name

Returns:

Type Description
str

'P' for project version or empty string for the normal version