Skip to content

Precast Element Properties

Class full path: NemAll_Python_Precast.PrecastElementProperties

PrecastElementProperties class

Attributes

ElementType: int property

Property for Element Type

ElementTypeCatGUID: GUID property

Property for ElementTypeCatGUID

Factory: str property

Property for Factory

FactoryCatAddressOffset: int property

Property for Factory Catalog Address Offset

Layers: typing.List[PrecastLayer] property

Property for Layers

Norm: str property

Property for Norm

NormCatAddressOffset: int property

Property for Norm Catalog Address Offset

PieceFactor: int property

Property for Piece Factor

PosNr: int property

Property for PosNr

PosNrText: str property

Property for PosNrText

ReferencePoint: Point3D property

Property for ReferencePoint

SpanDirection: Point3D property

Property for SpanDirection

ViewDirection: Point3D property

Property for ViewDirection

Functions

SetElementTypeCatalogGUID(elementType)

Set the element Type Catalog GUID

Parameters:

Name Type Description Default
elementType int

Element type

required

Returns:

Type Description
GUID

Element type catalog GUID

SetFactoryCatalogAddressOffset(factory)

Set the factoryCatAddressOffset

Parameters:

Name Type Description Default
factory str

Factory name

required

Returns:

Type Description
int

Factory catatalog address offset

SetNormCatalogAddressOffset(norm)

Set the normCatAddressOffset

Parameters:

Name Type Description Default
norm str

Norm name

required

Returns:

Type Description
int

Norm catalog address offset

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop PrecastElementProperties

Properties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

initialize

__repr__()

Convert to string