Skip to content

Reinforcement Label Properties

Class full path: NemAll_Python_Reinforcement.ReinforcementLabelProperties

Attributes

ShowBarCount: bool property

Set/get the show state for the bar count

ShowBarDiameter: bool property

Set/get the show state for the bar diameter

ShowBarDistance: bool property

Set/get the show state for the bar distance

ShowBarLayer: bool property

Set/get the show state for the bar layer

ShowBarLength: bool property

Set/get the show state for the bar length

ShowBarPlace: bool property

Set/get the show state for the bar place

ShowBendingShape: bool property

Set/get the show state for the bending shape

ShowPositionAtEnd: bool property

Set/get the show state for the bar diameter

ShowPositionNumber: bool property

Set/get the show state for the position number

ShowSteelGrade: bool property

Set/get the show state for the steel grade

ShowTwoLineText: bool property

Set/get the show state for the two line text

Functions

__init__ overload

__init__()

initialize

__init__(prop)

Copy constructor

Parameters:

Name Type Description Default
prop ReinforcementLabelProperties

Properties to copy

required

__repr__()

convert the list to a string