Skip to content

Outline Shape

Class full path: NemAll_Python_Precast.OutlineShape

Bases: IntEnum

Enumaration class containing outline types of linear fixtures

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key Union[str, int, float]

value key

required

Returns:

Type Description
OutlineShape

value for the key