Skip to content

Attribute String

Class full path: NemAll_Python_BaseElements.AttributeString

Bases: Attribute

Attributes

Id: int property

Property for id

Value: str property

Property for value

Functions

__eq__(props)

Compare operator

Parameters:

Name Type Description Default
props AttributeString

Properties to compare

required

Returns:

Type Description
bool

Properties are equal: true/false

__init__ overload

__init__()

initialize

__init__(id, value)

Constructor

Parameters:

Name Type Description Default
id int

Attribute id

required
value str

Attribute value

required

__repr__()

convert the list to a string