Skip to content

Section Definition Properties

Class full path: NemAll_Python_BasisElements.SectionDefinitionProperties

Section definition properties

Attributes

ClippingPathProperties: ClippingPathProperties property

Set/Get the clipping path properties

IsAdvancedOn: bool property

Property for type of section architecture= OFF /Engineering = ON

IsSectionBodyOn: bool property

Whether to show the section body

RefMode: RefMode_Enum property

Property for the reference mode

SectionType: SectionType_Enum property

Property for type of section

ViewInputType: ViewInputType_Enum property

Property for the view input type

Classes

RefMode_Enum

Bases: IntEnum

View input type

Attributes

eFolded = 1 class-attribute instance-attribute

Folded mode

eObserver = 0 class-attribute instance-attribute

Observer mode

SectionType_Enum

Bases: IntEnum

Section type

Attributes

eHorizontalFromAbove = 2 class-attribute instance-attribute

Horizontal section with view direction from above

eHorizontalFromBelow = 3 class-attribute instance-attribute

Horizontal section with view direction from below (soffit)

eVertical = 1 class-attribute instance-attribute

Vertical section with a side view

ViewInputType_Enum

Bases: IntEnum

View input type

Functions

__init__()

initialize