Skip to content

Section Definition Data

Class full path: NemAll_Python_BasisElements.SectionDefinitionData

Section definition data

Attributes

ClippingPath: Polyline2D property

Set/get the clipping path

DefinitionProperties: SectionDefinitionProperties property

Set/Get the definition properties

DirectionVector: Vector3D property

Set/get the direction vector

HeightDirection: Vector3D property

Set/get the height direction

SectionBody: Polyhedron3D property

Set/get the section body

Functions

__init__()

initialize