Skip to content

Fixture Slide Properties

Class full path: NemAll_Python_Precast.FixtureSlideProperties

Representation of properties of a fixture slide

Attributes

EndScaleRange: float property

Property for end reference scale of slide

OffsetOfReferencePoint1: Vector3D property

Property for first offset value to reference point

OffsetOfReferencePoint2: Vector3D property

Property for second offset value to reference point

ReferencePoint: Point3D property

Property for reference point

ResizeSettingVx: FixtureCombinationType property

Property for resize setting for x direction

ResizeSettingVy: FixtureCombinationType property

Property for resize setting for y direction

ResizeSettingVz: FixtureCombinationType property

Property for resize setting for z direction

StartScaleRange: float property

Property for start reference scale of slide

Type: FixtureSlideType property

Property for type of slide

ViewType: FixtureSlideViewType property

Property for view type of slide

VisibilityGeo2D: bool property

Property for geometry 2D visibility of slide

VisibilityGeo3D: bool property

Property for geometry 3D visibility of slide

VisibilityLayerA: bool property

Property for layer A visibility of slide

VisibilityLayerB: bool property

Property for layer B visibility of slide

VisibilityLayerC: bool property

Property for layer C visibility of slide

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop FixtureSlideProperties

FixtureSlideProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

initialize

__repr__()

convert the list to a string