Skip to content

Macro Placement Properties

Class full path: NemAll_Python_BasisElements.MacroPlacementProperties

Represantation of the smart symbol's instance properties

Attributes

BillingCategory: int property writable

Get the Billing category

ConsiderType: ConsiderType property writable

Property for the type of adaptation behaviour of the smart symbol relating to finishing surfaces

Craft: int property writable

Get the Craft

DistortionState: bool property writable

Whether to allow the resize of the smart symbol

DomainType: int property writable

Get the Domain type?

HasParentModificationBehaviour: bool property writable

Get the Specific behavior for modification

HeightDefinitionType: HeightDefinitionType property writable

Property for height definition type

InOpeningState: bool property writable

Get the Is the macro placement inside opening ?

LeadingMacro: bool property

Is the macro placement a leading macro

LinkType: LinkType property writable

Get the Link type

Mass_V6: float property writable

Get the Mass attribute V6

Mass_V7: float property writable

Get the Mass attribute V7

Mass_V8: float property writable

Get the Mass attribute V8

Mass_V9: float property writable

Get the Mass attribute V9

Matrix: Matrix3D property writable

Get the Matrix for location in world coordinate system

MirrorState: bool property writable

Get the Was the macro placement mirrored ?

Name: str property writable

Get the Name

PositionNr: int property writable

Property for the mark number

SubType: int property writable

Get the Subtype?

Type: int property writable

Get the Type?

UnitFactor: float property writable

Get the Unit factor

UseAlways2DRepInGroundView: bool property writable

Whether to always use the 2D representation in ground view

UseDrawOrder: bool property writable

Whether to use the draw order (sequence) setting of the smart symbol's instance (true) or from the elements included in the macro slide

UseFormat: bool property writable

Whether to use the format setting (pen, stroke, color) of the smart symbol's instance (true) or from the elements included in the macro slide

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop MacroPlacementProperties

MacroPlacementProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__ overload

__init__()

initialize

__init__(element)

Copy constructor

Parameters:

Name Type Description Default
element MacroPlacementProperties

Element to copy

required

__repr__()

Convert to string