Skip to content

Attribute Double

Class full path: NemAll_Python_BaseElements.AttributeDouble

Bases: Attribute

Attributes

Id: int property

attribute id

Value: float property

attribute value

Functions

__eq__(props)

Compare operator

Parameters:

Name Type Description Default
props AttributeDouble

Properties to compare

required

Returns:

Type Description
bool

Properties a equal: true/false

__init__ overload

__init__()

initialize

__init__(id, value)

Constructor

Parameters:

Name Type Description Default
id int

Attribute id

required
value float

Attribute value

required

__repr__()

convert the list to a string