Skip to content

Layout Border Definition

Class full path: NemAll_Python_BaseElements.LayoutBorderDefinition

Border definition

Attributes

DistanceBinding: float property writable

Set/get the distance binding

DistanceDefault: float property

Set/get the default distance

ExtraLineColor: int property

Set/get the extra line color

ExtraLinePen: int property

Set/get the extra line pen

ExtraLineStroke: int property

Set/get the extra line stroke

FoldingBindingWidth: float property

Set/get the

FoldingPageHeight: float property

Set/get the folding - height of the pages

FoldingPageHeightTolNeg: float property

Set/get the folding - max. negative tolerance of page height

FoldingPageHeightTolPlus: float property

Set/get the folding - max. positive tolerance of page height

FoldingPageWidth: float property

Set/get the folding - width of the pages

FoldingPageWidthTolNeg: float property

Set/get the folding - max. negative tolerance of page width

FoldingPageWidthTolPlus: float property

Set/get the folding - max. positive tolerance of page width

FoldingType: int property

Set/get the folding type

Index: int property

Set/get the index

InnerLineColor: int property

Set/get the inner line color

InnerLinePen: int property

Set/get the inner line pen

InnerLineStroke: int property

Set/get the inner line stroke

Name: str property

Get/set the name

OuterLineColor: int property

Set/get the outer line color

OuterLinePen: int property

Set/get the outer line pen

OuterLineStroke: int property

Set/get the outer line stroke

UseExtraLine: bool property

Set/get the extra line state

UseInnerLine: bool property

Set/get the inner line state

UserDefined: bool property

Set/get the user defined state

Functions

__init__()

initialize