Skip to content

Dimension Properties

Class full path: NemAll_Python_BasisElements.DimensionProperties

Properties of Dimension Line and Elevation Points

Attributes

ElevationBaseOffset: float property

Property for the elevation base offset

FontIDDimensionNumber: int property

Property for the font ID of the dimension number

IsAbsoluteElevation: bool property

Whether to use the absolute elevation values

LeadingCharacter: str property

Property for the leading characters

PointSymbol: int property

Property for the point symbol of the elevation

PointSymbolEnd: int property

Property for the point symbol at the end of the dimension line

PointSymbolStart: int property

Property for the point symbol at the start of the dimension line

TailingCharacters: str property

Property for the tailing characters

TextHeightDimensionNumber: float property

Property for the height of the dimension number

TextLocation: TextLocation property

Property for the location of the dimension number

TextOffset: float property

Offset of text from dimension line

Functions

__init__ overload

__init__()

initialize

__init__(doc, dimensioning)

Default constructor

Parameters:

Name Type Description Default
doc DocumentAdapter

document adapter

required
dimensioning Dimensioning

type of the dimension line

required
__init__(arg)

Copy constructor Args: arg: Dimension properties to copy