Skip to content

Geometry Expansion Util

Class full path: NemAll_Python_Reinforcement.GeometryExpansionUtil

Utility for geometry expansion for reinforcement creation based on geometry of existing model objects

Functions

GetLineAbove(point, base_line, arg4, view_id)

Get the line above the base line and the input point

Parameters:

Name Type Description Default
point Point2D

input point

required
base_line Line2D

base line

required
arg4 bool

bool

required
view_id int

view id

required

Returns:

Type Description
bool

line was found true/false

Line2D

found line

float

minimum z coordinate

float

maximum z coordinate

GetLineAtPoint(point, dir_vec, arg4, arg5)

Get the line at the defined point of the base line

Parameters:

Name Type Description Default
point Point2D

point on the base line

required
dir_vec Vector2D

direction vector

required
arg4 bool

bool

required
arg5 float

float

required

Returns:

Type Description
bool

line was found true/false

Line2D

found line

float

minimum z coordinate

float

maximum z coordinate

int

view id

GetLineFromPoint(doc, point, view_proj, arg5)

Get the line near to the input point

Parameters:

Name Type Description Default
doc DocumentAdapter

document adapter

required
point Point2D

input point

required
view_proj ViewWorldProjection

view world projection

required
arg5 bool

bool

required

Returns:

Type Description
bool

line was found true/false

Line2D

found line

float

minimum z coordinate

float

maximum z coordinate

BaseElementAdapter

element which the found line belongs to

Matrix3D

view-to-model transformation matrix, if the line was found in a UVS identity matrix, if the line was found in the model

int

view id

GetLineLeft(point, base_line, arg4, view_id)

Get the line left from the base line and the input point

Parameters:

Name Type Description Default
point Point2D

input point

required
base_line Line2D

base line

required
arg4 bool

true/false

required
view_id int

view id

required

Returns:

Type Description
bool

line was found true/false

Line2D

found line

float

minimum z coordinate

float

maximum z coordinate

__init__ overload

__init__()

initialize

__init__(pMsgInfo, use3DGeometry)

Constructor

Parameters:

Name Type Description Default
pMsgInfo AddMsgInfo

Additional message info

required
use3DGeometry bool

Use the 3D geometry for the expansione: true/false

required