Skip to content

Project Attribute Service

Class full path: NemAll_Python_BaseElements.ProjectAttributeService

Implementation of the project attribute service

Functions

ChangeAttributeFromCurrentProject overload

ChangeAttributeFromCurrentProject(attributeNumber, newValue, doc) staticmethod

Change a project attribute from the current project

Parameters:

Name Type Description Default
attributeNumber int

Attribute number

required
newValue int

Attribute value

required
doc DocumentAdapter

Document

required
ChangeAttributeFromCurrentProject(attributeNumber, newValue, doc) staticmethod

Change a project attribute from the current project

Parameters:

Name Type Description Default
attributeNumber int

Attribute number

required
newValue float

Attribute value

required
doc DocumentAdapter

Document

required
ChangeAttributeFromCurrentProject(attributeNumber, newValue, doc) staticmethod

Change a project attribute from the current project

Parameters:

Name Type Description Default
attributeNumber int

Attribute number

required
newValue str

Attribute value

required
doc DocumentAdapter

Document

required

ChangeAttributesFromCurrentProject(attributes, doc) staticmethod

Change project attributes from the current project

Parameters:

Name Type Description Default
attributes List[Tuple[int, Union[int, float, str]]]

Attributes

required
doc DocumentAdapter

Document

required

GetAttributesFromAllProjects() staticmethod

Get the project attributes from all projects

Returns:

Type Description
List[Tuple[int, Union[int, float, str]]]

Attributes from all projects as tuples (attributeNumber, attributeValue)

GetAttributesFromCurrentProject() staticmethod

Get the attributes from the current project

Returns:

Type Description
List[Tuple[int, Union[int, float, str]]]

Attributes from the current project as tuples (attributeNumber, attributeValue)