Skip to content

Hidden Section Lines Properties

Class full path: NemAll_Python_BasisElements.HiddenSectionLinesProperties

Properties of hidden section lines of a UVS

Attributes

HiddenSectionLinesColor: int property

Property for color ID

HiddenSectionLinesLayer: int property

Property for layer ID

HiddenSectionLinesLineType: int property

Property for stroke ID

HiddenSectionLinesPen: int property

Property for pen ID

IsHiddenSectionLinesColorFromLayer: bool property

Whether to get the color ID from the layer definition

IsHiddenSectionLinesLineTypeFromLayer: bool property

Whether to get the stroke ID from the layer definition

IsHiddenSectionLinesOn: bool property

Whether to draw hidden section lines

IsHiddenSectionLinesPenFromLayer: bool property

Whether to get the pen ID from the layer definition

Functions

__init__()

initialize