Skip to content

Attribute Set

Class full path: NemAll_Python_BaseElements.AttributeSet

Attribute set class

Attributes

Attributes: typing.List property

Property for attribute elements

Functions

GetAttributes()

Get the Attributes

Returns:

Type Description
List

Vector of Attribute elements

SetAttributes(elements)

Set the Attributes

Parameters:

Name Type Description Default
elements List

Attribute elements

required

__eq__(props)

Compare operator

Parameters:

Name Type Description Default
props AttributeSet

Properties to compare

required

Returns:

Type Description
bool

Properties are equal: true/false

__init__ overload

__init__()

initialize

__init__(elements)

Constructor

Parameters:

Name Type Description Default
elements List

Attribute elements

required

__repr__()

convert the list to a string