Skip to content

Project Service

Class full path: NemAll_Python_BaseElements.ProjectService

Functions

CloseAllplan() staticmethod

Close Allplan

GetCurrentProjectNameAndHost() staticmethod

Get the project and host name

Returns:

Type Description
str

project name

str

host name

GetCurrentUserAsBwsPath() staticmethod

Get the current user as BWS path

Returns:

Type Description
str

User as BWS path

GetProjectPath(hostName, projectName) staticmethod

Get the project path

Parameters:

Name Type Description Default
hostName str

Host name

required
projectName str

Project name

required

Returns:

Type Description
str

Error

str

project path

OpenProject(doc, hostName, projectName) staticmethod

Open the project

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
hostName str

Host name

required
projectName str

Project name

required

Returns:

Type Description
str

String with result: "Active project" if the target project equals currently opened project TODO: even if the target project was active, the result was "project opened" "Project not exist" if couldn't find the project "Not possible to open the project" if project was found, but opening was not successful "Project opened" if opening was successful