Skip to content

Bitmap Area Properties

Class full path: NemAll_Python_BasisElements.BitmapAreaProperties

Properties of Bitmap Area

Attributes

BitmapName: str property

Property for bitmap name of the bitmap area

DirectionToReferenceLine: int property

Property for direction to reference line

ReferencePoint: Point2D property

Property for reference point

RotationAngle: Angle property

Property for rotation angle

TransparentColor: ARGB property

Property for transparent color

TransparentColorTolerance: int property

Property for transparent color tolerance

UseDirectionToReferenceLine: bool property

Property for usage of direction to reference line

UseMetricalValues: bool property

Property for metrical values

UsePixelMask: bool property

Property for usage of mask black pixels

UseReferencePoint: bool property

Property for usage of reference point

UseRepeatTile: bool property

Property for repeat tile

XOffset: float property

Property for X offset value

XScalingFactor: float property

Property for X scaling factor

YOffset: float property

Property for Y offset value

YScalingFactor: float property

Property for Y scaling factor

Functions

__eq__(prop)

equal operator

Parameters:

Name Type Description Default
prop BitmapAreaProperties

BitmapProperties to compare

required

Returns:

Type Description
bool

true if they are equal, false otherwise

__init__()

initialize

__repr__()

convert the list to a string