Skip to content

Cone3D

Class full path: NemAll_Python_Geometry.Cone3D

3D cone

Attributes

Apex: Point3D property

Get and set the apex property

LocalPlacement: AxisPlacement3D property

Get and set the local placement property

MajorRadius: float property

Get and set the major radius property

MinorRadius: float property

Get and set the minor radius property

Functions

GetApex()

Get Apex of the Cone in the local coordinate system

Returns:

Type Description
Point3D

Reference to Apex.

GetApexParent()

Get Apex of the Cone in the parent coordinate system

Returns:

Type Description
Point3D

Reference to Apex.

GetCenter()

Get Center of the Cone

Returns:

Type Description
Point3D

Reference to Center.

GetHeight()

Get Height of the Cone

Returns:

Type Description
float

Reference to Height of the Cone.

GetLocalPlacement()

Get Local Placement

Returns:

Type Description
AxisPlacement3D

Reference to Local Placement.

GetMajorRadius()

Get Major Radius of the Cone

Returns:

Type Description
float

Reference to MajorRadius.

GetMinMax()

Get MinMax of the Cone

Returns:

Type Description
MinMax3D

Reference to MinMax of the Cone.

GetMinorRadius()

Get Minor Radius of the Cone

Returns:

Type Description
float

Reference to MinorRadius.

GetXAxis()

Get X-Axis of the placement of the Cone

Returns:

Type Description
Vector3D

Reference to X-Axis.

GetZAxis()

Get Z - axis of the placement of the Cone

Returns:

Type Description
Vector3D

Reference to Z-axis.

IsCircular()

Circularity check for the Cone

Returns:

Type Description
bool

true/false

IsOblique()

Perpendicularity check for the Cone

Returns:

Type Description
bool

true/false

IsValid()

Validity check for the Cone

Returns:

Type Description
bool

true/false

SetApex(apex)

Set Apex in the local coordinate system

Parameters:

Name Type Description Default
apex Point3D

New Apex.

required

SetApexParent(apex)

Set Apex in the parent coordinate system

Parameters:

Name Type Description Default
apex Point3D

New Apex.

required

SetCenter(center)

Set center

Parameters:

Name Type Description Default
center Point3D

New center.

required

SetHeight(height)

Set Height of the Cone

Parameters:

Name Type Description Default
height float

New height.

required

SetLocalPlacement(placement)

Set Local Placement.

Parameters:

Name Type Description Default
placement AxisPlacement3D

Local Placement.

required

SetMajorRadius(radius)

Set Major Radius of the Cone

Parameters:

Name Type Description Default
radius float

New major radius.

required

SetMinorRadius(radius)

Set Minor Radius of the Cone

Parameters:

Name Type Description Default
radius float

New minor radius.

required

__eq__(cone)

Comparison of cones without tolerance.

Be careful, this method work without tolerance!

Parameters:

Name Type Description Default
cone Cone3D

Compared cone.

required

Returns:

Type Description
object

True when cones are equal, otherwise false.

__init__ overload

__init__()

initialize

__init__(cone)

Copy constructor.

Parameters:

Name Type Description Default
cone Cone3D

Cone which will be copied.

required
__init__(refPlacement, radiusMajor, radiusMinor, apex)

Constructor.

Height of the Cone is z-coordinate of the Apex.

Parameters:

Name Type Description Default
refPlacement AxisPlacement3D

Local Placement of the Cone.

required
radiusMajor float

Major radius of the Cone.

required
radiusMinor float

Minor radius of the Cone.

required
apex Point3D

Apex of the Cone

required
__init__(radiusMajor, radiusMinor, apex)

Constructor.

Height of the Cone is z-coordinate of the Apex.

Parameters:

Name Type Description Default
radiusMajor float

Major radius of the Cone.

required
radiusMinor float

Minor radius of the Cone.

required
apex Point3D

Apex of the Cone

required

__repr__()

convert the list to a string