Skip to content

Attribute String Vec

Class full path: NemAll_Python_BaseElements.AttributeStringVec

Bases: Attribute

Attributes

Id: int property

Property for id

Value: VecStringList property

Property for value

Functions

GetValue()

Get the attribute value

Returns:

Type Description
VecStringList

Attribute value

__eq__(props)

Compare operator

Parameters:

Name Type Description Default
props AttributeStringVec

Properties to compare

required

Returns:

Type Description
bool

Properties are equal: true/false

__init__ overload

__init__()

initialize

__init__(id, value)

Constructor

Parameters:

Name Type Description Default
id int

Attribute id

required
value VecStringList

Attribute value

required

__repr__()

convert the list to a string