Skip to content

Macro Sub Type

Class full path: NemAll_Python_Precast.MacroSubType

Bases: IntEnum

Enumeration class containing fixture sub types

Functions

__getitem__(key)

get the item for a key

Parameters:

Name Type Description Default
key Union[str, int, float]

value key

required

Returns:

Type Description
MacroSubType

value for the key