Skip to content

Bar Area Placement Service

Class full path: NemAll_Python_Reinforcement.BarAreaPlacementService

Functions

AddOpeningPolygon(openingPol, offset)

Add an opening polygon

Parameters:

Name Type Description Default
openingPol Polygon3D

Opening polygon

required
offset float

Offset from the polygon

required

Calculate(doc, barPlacementProp, placementMatrix, concreteCoverZDir)

Calculate the meshes

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
barPlacementProp BarAreaPlacementProperties

Placement properties

required
placementMatrix Matrix3D

Placement matrix

required
concreteCoverZDir float

Concrete cover in the local z direction

required

Returns:

Type Description
List[Tuple[Vector3D, Line3D, Line3D, int, int]]

list with tuples containing placement data (direction vector, bar line start, bar line end, bar count, position number)

SetOuterPolygon(placementPol, offset)

Constructor

Parameters:

Name Type Description Default
placementPol Polygon3D

Placement polygon

required
offset float

Offset from the polygon

required

__init__()

initialize