Skip to content

Structural Column Properties

Class full path: NemAll_Python_ArchElements.StructuralColumnProperties

Bases: StructuralElementProperties, ArchBaseProperties

Implementation of Structural Framing Column properties

Functions

GetHeight()

Get the Column Height

Returns:

Type Description
float

Height

GetPosition()

Get the Column position in world coordinate system

Returns:

Type Description
Point3D

Point with column position

SetAnchorPointProperties(anchorPoint, offset)

Set the Column Anchor Point Properties

Parameters:

Name Type Description Default
anchorPoint CustomBoxPoint

anchor point position

required
offset Point2D

offset from start anchor point

required

SetHeight(z, doc, planeReferences)

Set the Column Height

Parameters:

Name Type Description Default
z float

Height of column

required
doc DocumentAdapter

Document

required
planeReferences PlaneReferences

Plane references

required

SetHeightProperties(doc, planeReferences)

Set the Column Height Properties

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
planeReferences PlaneReferences

Height Properties of Column, as PlaneReferences type

required

SetHeightPropsByPlacementPoint(doc, planeReferences, zCoord)

Set Height Properties using placement point

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
planeReferences PlaneReferences

Plane references

required
zCoord float

zCoordinate of the placement point

required

SetPosition(x, y, z)

Set the Column position in world coordinate system

Parameters:

Name Type Description Default
x float

x position

required
y float

y position

required
z float

z position

required

__init__ overload

__init__()

initialize

__init__(structuralColumnProps)

Copy constructor

Parameters:

Name Type Description Default
structuralColumnProps StructuralColumnProperties

Structural Column properties

required