Skip to content

Reinforcement Util

Class full path: NemAll_Python_Reinforcement.ReinforcementUtil

Functions

GetNextBarPositionNumber(doc) staticmethod

Get the next free bar position number

Returns:

Type Description
int

Next bar position number

Args: doc: Document

GetNextMeshPositionNumber(doc) staticmethod

Get the next free mesh position number

Returns:

Type Description
int

Next mesh position number

Args: doc: Document

Rearrange(doc, fromBarPosition, fromMeshPosition, createUndoStep=True) staticmethod

Rearrange the reinforcement position numbers

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fromBarPosition int

Rearrange from bar position

required
fromMeshPosition int

Rearrange from mesh position

required
createUndoStep bool

Create the undo step

True

__init__()

initialize