Skip to content

Bitmap Area Element

Class full path: NemAll_Python_BasisElements.BitmapAreaElement

Bases: BasisElement, AllplanElement

Representation of Bitmap Area

Functions

GetBitmapAreaProperties()

Get the BitmapArea properties

Returns:

Type Description
BitmapAreaProperties

BitmapArea properties

SetBitmapAreaProperties(bitmapAreaProp)

Set the bitmapArea properties

Parameters:

Name Type Description Default
bitmapAreaProp BitmapAreaProperties

Bitmap area properties

required

__init__ overload

__init__()

initialize

__init__(commonProp, bitmapAreaProp, geometryObject)

Constructor

Parameters:

Name Type Description Default
commonProp CommonProperties

Common properties

required
bitmapAreaProp BitmapAreaProperties

BitmapArea properties

required
geometryObject object

Geometry element

required
__init__(bitmapAreaElement)

Copy constructor

Parameters:

Name Type Description Default
bitmapAreaElement BitmapAreaElement

Bitmap area element element to copy

required

__repr__()

convert the list to a string