Skip to content

Polyhedron3D Builder

Class full path: NemAll_Python_Geometry.Polyhedron3DBuilder

3D polyhedron builder

Functions

AppendVertex(vertex)

Append new vertex

Parameters:

Name Type Description Default
vertex Point3D

Point in world coordinate system

required

Returns:

Type Description
eGeometryErrorCode

eOK if success,

int

Index where vertex has been inserted

Complete()

Finalize polyhedron

Recalculate cached minmax of modified polyhedron

Returns:

Type Description
eGeometryErrorCode

eOK if success

SetVertex(vertexIndex, vertex)

Set vertex at the given index

Parameters:

Name Type Description Default
vertexIndex int

Index of updated vertex

required
vertex Point3D

Point in world coordinate system

required

Returns:

Type Description
eGeometryErrorCode

eOK if success

__init__(polyhedron)

Constructor

Parameters:

Name Type Description Default
polyhedron Polyhedron3D

Polyhedron where vertices will be modified

required