Skip to content

Layout File Service

Class full path: NemAll_Python_BaseElements.LayoutFileService

Functions

AssignPrintProfile(doc, printProfile)

Set the print profile of the active document

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
printProfile str

Full name of the print profile

required

CreateMasterLayoutElement(doc, layoutMasterData)

Create the master layout element

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
layoutMasterData LayoutMasterData

Layout master data

required

DeleteDocument(doc)

Delete the content of the active document

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required

ExportDWG(doc, layoutFileIndex, fileName, configFileName)

Export the data to a DWG file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
layoutFileIndex int

Index of the layout file

required
fileName str

Name of the DWG file

required
configFileName str

Name of the DWG configuration file

required

ExportPDF(doc, layoutFileIndex, fileName, configFileName)

Export the data to a PDF file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
layoutFileIndex int

Index of the layout file

required
fileName str

Name of the PDF file

required
configFileName str

Name of the PDF configuration file

required

ImportDWG(doc, fileName, configFileName, placePnt)

Import the data from an DWG file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileName str

Name of the DWG file

required
configFileName str

Name of the DWG configuration file

required
placePnt Point2D

Placement point of the data

required

InsertDrawingFile(doc, fileIndexList, placePnt, rotationAngle, scale, clipBoxLeftBottom, clipBoxRightTop, layerList, textFactor, bUseRefPnt, refPnt, drawingMinMaxClipping)

Insert drawing files in the layout file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document

required
fileIndexList List[int]

List with the drawing file indices

required
placePnt Point2D

Placement point

required
rotationAngle float

Rotation angle

required
scale float

Scale

required
clipBoxLeftBottom Point2D

Left bottom point of the clipping box

required
clipBoxRightTop Point2D

Top right point of the clipping box

required
layerList Union[List[int], VecIntList]

List with the insertion layers

required
textFactor float

Text factor

required
bUseRefPnt bool

Use the reference point for the placement

required
refPnt Point2D

Reference point of the drawing file

required
drawingMinMaxClipping MinMax3D

Min/max coordinates of the clipping area from the drawing file

required

LoadFile(doc, fileIndex)

Load a layout file

Parameters:

Name Type Description Default
doc DocumentAdapter

Document adapter

required
fileIndex int

Index of the layout file

required

__init__()

initialize