Skip to content

Attribute Date

Class full path: NemAll_Python_BaseElements.AttributeDate

Bases: Attribute

Attributes

Day: int property

Property for day value

Id: int property

Property for id

Month: int property

Property for month value

Year: int property

Property for year value

Functions

__eq__(props)

Compare operator

Parameters:

Name Type Description Default
props AttributeDate

Properties to compare

required

Returns:

Type Description
bool

Properties a equal: true/false

__init__ overload

__init__()

initialize

__init__(id, day, month, year)

Constructor

Parameters:

Name Type Description Default
id int

Attribute id

required
day int

day value

required
month int

month value

required
year int

year value

required

__repr__()

convert the list to a string