Skip to content

Assoc View Element Adapter

Class full path: NemAll_Python_IFW_ElementAdapter.AssocViewElementAdapter

Bases: BaseElementAdapter

Implementation of the associative view element adapter

This adapter offers access to some methods and properties of unified views or sections. Note, that it does NOT offer access to the reinforcement views and sections.

Functions

GetTransformationMatrix()

Get the transformation matrix of the unified view or section

Returns:

Type Description
Matrix3D

Transformation matrix of the unified view or section

IsNull()

Check for an empty element

Returns:

Type Description
bool

Element is empty: true/false

__init__ overload

__init__()

initialize

__init__(object) staticmethod

Constructor

__init__(ele)

Constructor

Parameters:

Name Type Description Default
ele BaseElementAdapter

Base element adapter

required