Skip to content

Profile Catalog Service

Class full path: NemAll_Python_ArchElements.ProfileCatalogService

Functions

GetProfileBoundaryPath(fullProfileName) staticmethod

Get the profile boundary path

Parameters:

Name Type Description Default
fullProfileName str

Profile name with path

required

Returns:

Type Description
Path2D

Profile boundary curve as Path2D

GetProfileBoundaryPolyline(fullProfileName) staticmethod

Get the profile boundary polyline

Parameters:

Name Type Description Default
fullProfileName str

Profile name with path

required

Returns:

Type Description
Polyline2D

Profile boundary curve as Polyline2D

GetProfileGeometry(fullProfileName) staticmethod

Get the profile geometry

Parameters:

Name Type Description Default
fullProfileName str

Profile name with path

required

Returns:

Type Description
BRep3D

Profile geometry as BRep3D

GetProfilePlacementPoint(fullProfileName) staticmethod

Get the profile placement point

Parameters:

Name Type Description Default
fullProfileName str

Profile name with path

required

Returns:

Type Description
Point3D

Profile placement point as Point3D